PAT(A) 1064. Complete Binary Search Tree (30)


原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1064

1064. Complete Binary Search Tree (30)


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greater than or equal to the node's key. Both the left and right subtrees must also be binary search trees. A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right. Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input: 10 1 2 3 4 5 6 7 8 9 0 Sample Output: 6 3 8 1 5 7 9 0 2 4

题目大意

将一系列数字建立成完全搜索二叉树,当数据固定时,这种建立的树是唯一的,输出其层序遍历。

解题报告

对于完全树,当树的节点数确定时,是能够确定他的左边和右边节点数量的。又由于是搜索树,所以根节点必定是第(左子树节点数 + 1)个数,故先将原序列排序,便可知道根节点的数字再其中的位置,通过分治思想再建立左子树和右子树。

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
/*
* Problem: 1064. Complete Binary Search Tree (30)
* Author: HQ
* Time: 2018-03-07
* State: Done
* Memo:
*/
#include "cmath"
#include "iostream"
#include "vector"
#include "algorithm"
using namespace std;

vector<int> seq, tree;
int N;

void change(int pos, int b, int e) {
    if (b > e)
        return;
    int length = e - b + 1;
    if (length == 1) {
        tree[pos] = seq[b];
        return;
    }
    int left;
    int level = (int)(log(length) / log(2)) + 1;
    int lastlevel = length - pow(2, level - 1) + 1;
    int mid = pow(2, level - 2);
    if (lastlevel >= mid)
        left = mid * 2 - 1;
    else
        left = mid * 2 - 1 + lastlevel - mid;
    tree[pos] = seq[b + left];
    change(pos*2,b, b + left - 1);
    change(pos*2+1,b + left + 2 - 1,e);
}

int main() {
    cin >> N;
    int x;
    for (int i = 0; i < N; i++) {
        cin >> x;
        seq.push_back(x);
    }
    tree.resize(N + 1);
    sort(seq.begin(),seq.end());
    change(1,0,seq.size() - 1);
    for (int i = 1; i < N; i++)
        cout << tree[i]<< " ";
    cout << tree[N] << endl;
    system("pause");
}


发表评论:

评论列表: