PAT(A) 1075. PAT Judge (25)


原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1075

1075. PAT Judge (25)


The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20 20 25 25 30 00002 2 12 00007 4 17 00005 1 19 00007 2 25 00005 1 20 00002 2 2 00005 1 15 00001 1 18 00004 3 25 00002 2 25 00005 3 22 00006 4 -1 00001 2 18 00002 1 20 00004 1 15 00002 4 18 00001 3 4 00001 4 2 00005 2 -1 00004 2 0

Sample Output: 1 00002 63 20 25 - 18 2 00005 42 20 0 22 - 2 00007 42 - 25 - 17 2 00001 42 18 18 4 2 5 00004 40 15 0 25 -

题目大意

模拟Pat考试的判定,输出排名。

输入第一行为N(人数)、K(题目数)、M(提交记录)。

第二行为K个数,表示第i个题目的满分数。

再M行为提交记录,三个参数为人员Id,题号,分数,其中-1表示未能编译通过。

排序方式按总分高为先,若总分相同,AC题目多者为先,再同的话,Id小的为先。

总分相同的排名相同。

为提交过或所提交的没有一个编译成功的不显示。(提交但分数为0是显示的)

解题报告

标记每个人的每个题目的状态,再排序。 注意事项:

  1. 若编译成功,哪怕分数为0也要显示。
  2. 若显示,则提交过但未能编译成功的题目显示为0分,未提交过的题目显示为“-”。
  3. 注意检查每一种成绩状态的显示是否正确,有如下需要注意:
  4. 未提交过的。
  5. 提交过但没有一个编译成功的。
  6. 提交过,部分没有编译成功。
  7. 提交过,有编译成功项,但最终总分为0。
  8. 总分不为0,存在题目未提交,存在题目提交但编译不成功。
  9. 剩下的了。。。

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
#include "iostream"
#include "algorithm"
#include "vector"
using namespace std;

int N,K,M;
int fullMark[6];

struct node{
    int id;
    int score[6];//score[0]表示总分
    int numOfFull;
    bool isShown;
};

vector<struct node> users;

bool cmp(const struct node a,const struct node b){
    if(a.score[0] != b.score[0])
        return a.score[0] > b.score[0];
    if(a.numOfFull != b.numOfFull)
        return a.numOfFull > b.numOfFull;
    return a.id < b.id;
}

void init(){
    cin>>N>>K>>M;
    int i;
    for(i = 1; i <= K; i++)
        cin>>fullMark[i];
    struct node t = {0,{0,-1,-1,-1,-1,-1},0,false};
    users.resize(N + 1,t);
}
void submit(){
    int i;
    int id,proId,score;
    for(i = 0; i < M; i++){
        cin>>id>>proId>>score;
        if(score != -1)
            users[id].isShown = true;
        score = max(score,0);
        users[id].score[proId] = max(score,users[id].score[proId]);
    }
}

void cal(){
    int i,j;
    for(i = 0;i <= N; i ++){
        users[i].id = i;
        for(j = 1;j <= K; j++){
            if(users[i].score[j] == fullMark[j])
                users[i].numOfFull ++;
            if(users[i].score[j] > -1)
                users[i].score[0] += users[i].score[j];
        }
    }
}

void test(){
    int i;
    for(i = 0; i <= N; i++){
        cout<<users[i].id<<" "<<users[i].score[0]<<endl;
    }
}

void print_ans(){
    int i,j;
    int rank;
    for(i = 1; i <= N; i++){
        if(users[i].isShown){
            if( i == 1 || users[i].score[0] != users[i - 1].score[0])
                rank = i;
            printf("%d %05d %d",rank,users[i].id,users[i].score[0]);
            for(j = 1; j <= K; j++)
                if (users[i].score[j] > -1){
                    printf(" %d",users[i].score[j]);
                }else
                    printf(" -");
        cout<<endl;
        }
    }
}

int main(){
    //freopen("test.out","w",stdout);
    init();
    submit();
    cal();
    sort(users.begin() + 1,users.end(),cmp);
    print_ans();
    //test();
    system("pause");
}


发表评论:

评论列表: