PAT(A) 1094. The Largest Generation (25)


原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1094

1094. The Largest Generation (25)


A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (< N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input: 23 13 21 1 23 01 4 03 02 04 05 03 3 06 07 08 06 2 12 13 13 1 21 08 2 15 16 02 2 09 10 11 2 19 20 17 1 22 05 1 11 07 1 14 09 1 17 10 1 18 Sample Output: 9 4

题目大意

给一个家族系谱的树,求人数最多的那一代。 首行为N,M,表示N个人和M个家庭。 后M行格式为,家族成员,其孩子数,孩子1,孩子2……

解题报告

树的层次遍历,用BFS,队列优化。记录每层的人员数。

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
#include "iostream"
#include "vector"
#include "queue"
using namespace std;

int N,M;
vector<vector<int>> G;
int level,ans;


void init(){
    cin>>N>>M;
    G.resize(N + 1);
    int i,k,j,x;
    for(i = 0; i < M; i++){
        cin>>x>>k;
        G[x].resize(k);
        for(j = 0; j < k; j++){
            cin>>G[x][j];
        }
    }
}

void bfs(){
    int root = 1;
    int x,i;
    queue<int> que;
    level = 1;
    ans = 1;

    int numInLevel = 0,numInNextLevel = 0,num = 0,tempLevel = 0;

    que.push(root);
    numInLevel ++;
    numInNextLevel;
    tempLevel ++;
    while(!que.empty()){
        x = que.front();
        que.pop();
        num ++;
        for(i = 0; i < G[x].size(); i++){
            que.push(G[x][i]);
            numInNextLevel ++;
        }
        if(num == numInLevel){
            if(numInNextLevel > ans){
                level = tempLevel + 1;
                ans = numInNextLevel;
            }
            tempLevel ++;
            numInLevel = numInNextLevel;
            numInNextLevel = 0;
            num = 0;
        }
    }

}

int main(){
    init();
    bfs();
    printf("%d %d",ans,level);
    //system("pause");
}


发表评论:

评论列表: