PAT(A) 1100. Mars Numbers (20)


原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1100

1100. Mars Numbers (20)


People on Mars count their numbers with base 13:

Zero on Earth is called "tret" on Mars. The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively. For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively. For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (< 100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input: 4 29 5 elo nov tam Sample Output: hel mar may 115 13

题目大意

将火星数字转换为地球数字,将地球数字转换为火星数字。

解题报告

有点字符串模拟的感觉,主要要做好不同情况下的逻辑判断。

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
#include "iostream"
#include "string"
#include "map"
#include "vector"
using namespace std;

string i2num[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct",   "nov", "dec"};;
string i2higherNum[13] = {"", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy","lok", "mer", "jou"};

bool isNum(string s){
    if(s[0] >= '0' && s[0] <= '9')
        return true;
    return false;
}

void cal(){
    int n;
    cin>>n;
    int x;
    string s;
    string s1,s2;
    getchar();
    for(int i=0;i<n;i++){
        getline(cin,s);
        if(isNum(s)){
            x = stoi(s);
            int a,b;
            a = x/13;
            b = x % 13;
            if(!a && !b)
                cout<<i2num[0]<<endl;
            if(!a && b)
                cout<<i2num[b]<<endl;
            if(a && !b)
                cout<<i2higherNum[a]<<endl;
            if(a && b)
                cout<<i2higherNum[a]<<" "<<i2num[b]<<endl;

        }else{
            if(s.length() == 4){
                cout<<0<<endl;
                continue;
            }
            s1 = string(s,0,3);
            x = 0;
            if(s.length()>3){
                s2 = string(s,4,3);
                for (int i = 1; i <= 12; i++) {
                    if (s1 == i2higherNum[i]) {
                        x += i * 13;
                    }
                    if (s2 == i2num[i]) {
                        x += i;
                    }
                }
            }else{
                for (int i = 1; i <= 12; i++) {
                    if (s1 == i2higherNum[i]) {
                        x += i * 13;
                    }
                    if (s1 == i2num[i]) {
                        x += i;
                    }
                }
            }
            cout<<x<<endl;
        }
    }
}

int main(){
    cal();
    system("pause");
}


发表评论:

评论列表: