PAT(A) 1105. Spiral Matrix (25)


原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1105

1105. Spiral Matrix (25)


This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input: 12 37 76 20 98 76 42 53 95 60 81 58 93 Sample Output: 98 95 93 42 37 81 53 20 76 58 60 76

题目大意

给N个数字,建立一个m行n列矩阵,要求m>=n,且m-n最小。 并将N个数字由大到小排序后由(0,0)按顺时针方向填入矩阵内。

解题报告

对N个数字排序,再建立m*n矩阵。

代码

  1
  2
  3
  4
  5
  6
  7
  8
  9
 10
 11
 12
 13
 14
 15
 16
 17
 18
 19
 20
 21
 22
 23
 24
 25
 26
 27
 28
 29
 30
 31
 32
 33
 34
 35
 36
 37
 38
 39
 40
 41
 42
 43
 44
 45
 46
 47
 48
 49
 50
 51
 52
 53
 54
 55
 56
 57
 58
 59
 60
 61
 62
 63
 64
 65
 66
 67
 68
 69
 70
 71
 72
 73
 74
 75
 76
 77
 78
 79
 80
 81
 82
 83
 84
 85
 86
 87
 88
 89
 90
 91
 92
 93
 94
 95
 96
 97
 98
 99
100
101
102
103
104
105
106
107
108
109
110
#include "iostream"
#include "math.h"
#include "algorithm"
#include "vector"
using namespace std;

int N;
vector<vector<int>> G;
vector<int> data;
int m,n;

bool cmp(int a,int b){
    return a>b;
}

void init(){
    cin>>N;
    int x;
    for(int i = 0; i < N; i++){
        cin>>x;
        data.push_back(x);
    }
}

void cal(){
    sort(data.begin(),data.end(),cmp);
    m = sqrt(N * 1.0);
    while(N % m){
        m ++;
    }
    m = max(m,N/m);
    n = N/m;
    G.resize(m);
    for(int i = 0; i < m; i ++)
        G[i].resize(n);
}

void build_G(){
    int k = 0;
    int mm = m - 1,nn = n;
    int i = 0,j = 0;
    while(k<N){
        if(nn){
            for(int t = 0; t < nn; t++){
                G[i][j] = k;
                k ++;
                j ++;
            }
            j --;
            i ++;
            nn--;
        }
        if(k >= N)
            break;
        if(mm){
            for(int t = 0; t < mm; t++){
                G[i][j] = k;
                k ++;
                i ++;
            }
            i --;
            j --;
            mm--;
        }
        if(k >= N)
            break;
        if(nn){
            for(int t = 0; t < nn; t++){
                G[i][j] = k;
                k ++;
                j --;
            }
            j ++;
            i --;
            nn--;
        }
        if(k >= N)
            break;
        if(mm){
            for(int t = 0; t < mm; t++){
                G[i][j] = k;
                k ++;
                i --;
            }
            i ++;
            j ++;
            mm--;
        }
    }
}

void print_GData(){
    for(int i =0;i<m;i++){
        cout<<data[G[i][0]];
        for(int j=1;j<n;j++)
            cout<<" "<<data[G[i][j]];
        cout<<endl;
    }
}

int main(){
    init();
    if(N == 0){
        cout<<data[0]<<endl;
        return 0;
    }
    cal();
    print_GData();
    system("pause");
}


发表评论:

评论列表: