PAT(A) 1104. Sum of Number Segments (20)


原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1104

1104. Sum of Number Segments (20)


Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input: 4 0.1 0.2 0.3 0.4 Sample Output: 5.00

题目大意

给一个序列,每一个元素都对应有多个以这个元素开头的顺序子序列。求这些序列的和。

解题报告

本题不用真正列出各种序列,通过分析我们可以得出每个元素在所有序列中出现了几次。 |序号| 元素|以0.1为首出现次数|0.2为首|0.3|0.4|总次数| |---|--|--|--|--|--|---| |1|0.1|4||||4| |2|0.2|3|3|||6| |3|0.3|2|2|2||6| |4|0.4|1|1|1|1|4| 可见第i个元素出现的次数为 (n + 1 - i) * i 由此可知答案为$\sum_{i=1}^n data_i (n+1-i)i$

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
#include "iostream"
using namespace std;

int main(){
    int n;
    double x,sum = 0;
    cin>>n;
    for(int i = 1; i <= n; i++){
        cin>>x;
        sum += x * (n + 1 - i) * i;
    }
    printf("%.2lf\n",sum);
    system("pause");
}


发表评论:

评论列表: