PAT(A) 1122. Hamiltonian Cycle (25)


原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1122

1122. Hamiltonian Cycle (25)


The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle. Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input: 6 10 6 2 3 4 1 5 2 5 3 1 4 1 1 6 6 3 1 2 4 5 6 7 5 1 4 3 6 2 5 6 5 1 4 3 6 2 9 6 2 1 6 3 4 5 2 6 4 1 2 5 1 7 6 1 3 4 5 2 6 7 6 1 2 5 4 3 1 Sample Output: YES NO NO NO YES NO

题目大意

给出一个图,判断一个路径是否是“Hamiltonian cycle”

解题报告

“Hamiltonian cycle”需要满足以下条件: 1. 从头到尾能走通,即存在路径。 2. 包含所有顶点。 3. 首尾一致。 4. 除首尾外,无多余重复顶点,即路径上定点数为图顶点数+1

代码

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
/*
* Problem: 1122. Hamiltonian Cycle (25)
* Author: HQ
* Time: 2018-03-12
* State: Done
* Memo:  set
*/
#include "iostream"
#include "set"
using namespace std;

int G[200 + 5][200 + 5];

int N, M,K;

int main() {
    cin >> N >> M;
    int x, y;
    for (int i = 0; i < M; i++) {
        cin >> x >> y;
        G[x][y] = 1;
        G[y][x] = 1;
    }
    cin >> K;
    set<int> route;
    for (int i = 0; i < K; i++) {
        int n;
        route.clear();
        cin >> n >> x;
        int start = x;
        int flag = true;
        route.insert(x);
        for (int j = 1; j < n; j++) {
            cin >> y;
            if (!G[x][y])
                flag = false;
            x = y;
            route.insert(y);
        }
        if (flag && route.size() == N && start == y && n == N + 1)
            cout << "YES" << endl;
        else
            cout << "NO" << endl;
    }
    system("pause");
}


发表评论:

评论列表: